import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^( *)(if(.|\\n)+?^(?!\\1 |#|\\1el|\\n))";
final String string = "if aaa=1:\n"
+ "# dfdf fdf\n"
+ " xxx\n"
+ " if cc = 4:\n"
+ " rrr\n"
+ " else:\n"
+ " ww\n"
+ " if aaaaa:\n"
+ " # dssfdsf\n"
+ " ttt\n"
+ "elif bb=2:\n\n"
+ " if ll is True:\n"
+ " return\n"
+ " yyy\n"
+ "else:\n"
+ " zzz\n"
+ "dfsdfsaa";
final String subst = "\\1\\2\\1# endif\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}