use strict;
my $str = 'if aaa=1:
# dfdf fdf
xxx
if cc = 4:
rrr
else:
ww
if aaaaa:
# dssfdsf
ttt
elif bb=2:
if ll is True:
return
yyy
else:
zzz
dfsdfsaa';
my $regex = qr/^( *)(if(.|\n)+?^(?!\1 |#|\1el|\n))/mp;
my $subst = '\\1\\2\\1# endif\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";