import Foundation
let pattern = ##"^( *)(if(.|\n)+?^(?!\1 |#|\1el|\n))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
if aaa=1:
# dfdf fdf
xxx
if cc = 4:
rrr
else:
ww
if aaaaa:
# dssfdsf
ttt
elif bb=2:
if ll is True:
return
yyy
else:
zzz
dfsdfsaa
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"\1\2\1# endif\n"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)