$re = '/^( *)(if(.|\n)+?^(?!\1 |#|\1el|\n))/m';
$str = 'if aaa=1:
# dfdf fdf
xxx
if cc = 4:
rrr
else:
ww
if aaaaa:
# dssfdsf
ttt
elif bb=2:
if ll is True:
return
yyy
else:
zzz
dfsdfsaa';
$subst = "\1\2\1# endif\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;