using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @""".*""\K|[^""\n]+";
string substitution = @"";
string input = @"{LID.P21_MA4_DB,new String[]{""Assumed probability of premise value(s)"",""This is only useful if a premise value is defined. Reduces query execution time.""}},
{LID.HOST_CFG_CASE_DOCS_FOLDER_SERVER_PATH,""Case documents folder path server-side""},
{LID.P12_MA3_T0,""Main form {0} - {1}""},";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}