re = /".*"\K|[^"\n]+/
str = '{LID.P21_MA4_DB,new String[]{"Assumed probability of premise value(s)","This is only useful if a premise value is defined. Reduces query execution time."}},
{LID.HOST_CFG_CASE_DOCS_FOLDER_SERVER_PATH,"Case documents folder path server-side"},
{LID.P12_MA3_T0,"Main form {0} - {1}"},'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result