use strict;
my $str = '{LID.P21_MA4_DB,new String[]{"Assumed probability of premise value(s)","This is only useful if a premise value is defined. Reduces query execution time."}},
{LID.HOST_CFG_CASE_DOCS_FOLDER_SERVER_PATH,"Case documents folder path server-side"},
{LID.P12_MA3_T0,"Main form {0} - {1}"},';
my $regex = qr/".*"\K|[^"\n]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";