# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(['"])(\d+)\1/$2/gm;t' <<< "'2018-12-09 07:29:00.0000000', 'US', 'MI', 'Detroit', '48206', '505', '68.61.112.245', '0', 'Verizon'
"