use strict;
my $str = '\'2018-12-09 07:29:00.0000000\', \'US\', \'MI\', \'Detroit\', \'48206\', \'505\', \'68.61.112.245\', \'0\', \'Verizon\'
';
my $regex = qr/(['"])(\d+)\1/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";