re = /(['"])(\d+)\1/m
str = '\'2018-12-09 07:29:00.0000000\', \'US\', \'MI\', \'Detroit\', \'48206\', \'505\', \'68.61.112.245\', \'0\', \'Verizon\'
'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result