#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\/\/.*|\/\*[^*]*\*\/"
Local $sString = "// comment" & @CRLF & _
"/// comment" & @CRLF & _
"non_comment;" & @CRLF & _
"non_comment; /* comment */" & @CRLF & _
"non_comment; // comment" & @CRLF & _
"/* comment */ non_comment;" & @CRLF & _
"/* comment */ non_comment; /* comment */" & @CRLF & _
"/* comment */ non_comment; // comment"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)