re = /\/\/.*|\/\*[^*]*\*\//m
str = '// comment
/// comment
non_comment;
non_comment; /* comment */
non_comment; // comment
/* comment */ non_comment;
/* comment */ non_comment; /* comment */
/* comment */ non_comment; // comment'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result