import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\/.*|\\/\\*[^*]*\\*\\/";
final String string = "// comment\n"
+ "/// comment\n"
+ "non_comment;\n"
+ "non_comment; /* comment */\n"
+ "non_comment; // comment\n"
+ "/* comment */ non_comment;\n"
+ "/* comment */ non_comment; /* comment */\n"
+ "/* comment */ non_comment; // comment";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}