$re = '/\/\/.*|\/\*[^*]*\*\//m';
$str = '// comment
/// comment
non_comment;
non_comment; /* comment */
non_comment; // comment
/* comment */ non_comment;
/* comment */ non_comment; /* comment */
/* comment */ non_comment; // comment';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;