package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/.*|\/\*[^*]*\*\/`)
var str = `// comment
/// comment
non_comment;
non_comment; /* comment */
non_comment; // comment
/* comment */ non_comment;
/* comment */ non_comment; /* comment */
/* comment */ non_comment; // comment`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}