# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=usa|united|states|america)(?:([a-z])([a-z\u00E0-\u00FC]+))/\U$1\E$2/g;t' <<< "usa
united states of america"