import Foundation
let pattern = #"(?=usa|united|states|america)(?:([a-z])([a-z\u00E0-\u00FC]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
usa
united states of america
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$1\E$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)