use strict;
my $str = 'usa
united states of america';
my $regex = qr/(?=usa|united|states|america)(?:([a-z])([a-z\u00E0-\u00FC]+))/p;
my $subst = '\\U$1\\E$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";