# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=usa|united|states|america)(?:([a-z])([a-z\u00E0-\u00FC]+))"
test_str = ("usa\n"
"united states of america")
subst = "\\U$1\\E$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.