const regex = /(?=usa|united|states|america)(?:([a-z])([a-z\u00E0-\u00FC]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=usa|united|states|america)(?:([a-z])([a-z\\u00E0-\\u00FC]+))', 'g')
const str = `usa
united states of america`;
const subst = `\U$1\E$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);