#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+) ?(?:change )?(?:-|too?) ?(\d+)"
Local $sString = "WC 12/10 change FC from 24 to 32" & @CRLF & _
"W/C 12/10 change fc from 401 to 340" & @CRLF & _
"W/C12/10 18 - 26" & @CRLF & _
"W?C 12/20/22 12 change to 34" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")