import re
regex = re.compile(r"(\d+) ?(?:change )?(?:-|too?) ?(\d+)", flags=re.MULTILINE)
test_str = ("WC 12/10 change FC from 24 to 32\n"
"W/C 12/10 change fc from 401 to 340\n"
"W/C12/10 18 - 26\n"
"W?C 12/20/22 12 change to 34\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")