package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+) ?(?:change )?(?:-|too?) ?(\d+)`)
var str = `WC 12/10 change FC from 24 to 32
W/C 12/10 change fc from 401 to 340
W/C12/10 18 - 26
W?C 12/20/22 12 change to 34
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}