import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+) ?(?:change )?(?:-|too?) ?(\\d+)";
final String string = "WC 12/10 change FC from 24 to 32\n"
+ "W/C 12/10 change fc from 401 to 340\n"
+ "W/C12/10 18 - 26\n"
+ "W?C 12/20/22 12 change to 34\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}