const regex = /(\d+) ?(?:change )?(?:-|too?) ?(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+) ?(?:change )?(?:-|too?) ?(\\d+)', 'gm')
const str = `WC 12/10 change FC from 24 to 32
W/C 12/10 change fc from 401 to 340
W/C12/10 18 - 26
W?C 12/20/22 12 change to 34
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}