package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((0[1-9]|[12]\d|3[01])-(0[1-9]|1[0-2])-[12]\d{3} (0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9]))$`)
var str = `10-12-2022 23:59:59
10-22-2022 2:59:59
10-12-2022 02:59:99
10-12-2022 02:59:59
00-12-2022 02:59:59
10-22-2022 02:59:59
10-12-2022 025959
// You can show origina post on albertcolom.com/blog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}