import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((0[1-9]|[12]\\d|3[01])-(0[1-9]|1[0-2])-[12]\\d{3} (0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9]))$";
final String string = "10-12-2022 23:59:59\n"
+ "10-22-2022 2:59:59\n"
+ "10-12-2022 02:59:99\n"
+ "10-12-2022 02:59:59\n"
+ "00-12-2022 02:59:59\n"
+ "10-22-2022 02:59:59\n"
+ "10-12-2022 025959\n\n"
+ "// You can show origina post on albertcolom.com/blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}