const regex = /^((0[1-9]|[12]\d|3[01])-(0[1-9]|1[0-2])-[12]\d{3} (0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9]))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((0[1-9]|[12]\\d|3[01])-(0[1-9]|1[0-2])-[12]\\d{3} (0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9]))$', 'gm')
const str = `10-12-2022 23:59:59
10-22-2022 2:59:59
10-12-2022 02:59:99
10-12-2022 02:59:59
00-12-2022 02:59:59
10-22-2022 02:59:59
10-12-2022 025959
// You can show origina post on albertcolom.com/blog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}