use strict;
my $str = '10-12-2022 23:59:59
10-22-2022 2:59:59
10-12-2022 02:59:99
10-12-2022 02:59:59
00-12-2022 02:59:59
10-22-2022 02:59:59
10-12-2022 025959
// You can show origina post on albertcolom.com/blog';
my $regex = qr/^((0[1-9]|[12]\d|3[01])-(0[1-9]|1[0-2])-[12]\d{3} (0[0-9]|1[0-9]|2[1-4]):(0[0-9]|[1-5][0-9]):(0[0-9]|[1-5][0-9]))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}