import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Rectangle[^>]*>3\\$[^<]*<\\/Rectangle>";
final String string = "<Rectangle is \n"
+ " good>99$1</Rectangle>\n"
+ "<Rectangle is \n"
+ " bad>99$2</Rectangle>\n"
+ "<Rectangle is \n"
+ " ugly>3$3</Rectangle>\n"
+ "<Rectangle is \n"
+ " fat>99$4</Rectangle>\n"
+ "<Rectangle is \n"
+ " janky6789>99$5</Rectangle>\n"
+ "<Rectangle is \n"
+ " 34+35>99$6</Rectangle>\n"
+ "<Rectangle is \n"
+ " <>>98$7</Rectangle>\n"
+ "<Rectangle is \n"
+ " chicken>3$8</Rectangle>\n"
+ "<Rectangle 1 is \n"
+ " holy>97$9</Rectangle>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}