$re = '/<Rectangle[^>]*>3\$[^<]*<\/Rectangle>/m';
$str = '<Rectangle is
good>99$1</Rectangle>
<Rectangle is
bad>99$2</Rectangle>
<Rectangle is
ugly>3$3</Rectangle>
<Rectangle is
fat>99$4</Rectangle>
<Rectangle is
janky6789>99$5</Rectangle>
<Rectangle is
34+35>99$6</Rectangle>
<Rectangle is
<>>98$7</Rectangle>
<Rectangle is
chicken>3$8</Rectangle>
<Rectangle 1 is
holy>97$9</Rectangle>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);