# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<Rectangle[^>]*>3\$[^<]*<\/Rectangle>"
test_str = ("<Rectangle is \n"
" good>99$1</Rectangle>\n"
"<Rectangle is \n"
" bad>99$2</Rectangle>\n"
"<Rectangle is \n"
" ugly>3$3</Rectangle>\n"
"<Rectangle is \n"
" fat>99$4</Rectangle>\n"
"<Rectangle is \n"
" janky6789>99$5</Rectangle>\n"
"<Rectangle is \n"
" 34+35>99$6</Rectangle>\n"
"<Rectangle is \n"
" <>>98$7</Rectangle>\n"
"<Rectangle is \n"
" chicken>3$8</Rectangle>\n"
"<Rectangle 1 is \n"
" holy>97$9</Rectangle>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.