const regex = /<Rectangle[^>]*>3\$[^<]*<\/Rectangle>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Rectangle[^>]*>3\\$[^<]*<\\\/Rectangle>', 'gm')
const str = `<Rectangle is
good>99\$1</Rectangle>
<Rectangle is
bad>99\$2</Rectangle>
<Rectangle is
ugly>3\$3</Rectangle>
<Rectangle is
fat>99\$4</Rectangle>
<Rectangle is
janky6789>99\$5</Rectangle>
<Rectangle is
34+35>99\$6</Rectangle>
<Rectangle is
<>>98\$7</Rectangle>
<Rectangle is
chicken>3\$8</Rectangle>
<Rectangle 1 is
holy>97\$9</Rectangle>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}