use strict;
my $str = '<Rectangle is
good>99$1</Rectangle>
<Rectangle is
bad>99$2</Rectangle>
<Rectangle is
ugly>3$3</Rectangle>
<Rectangle is
fat>99$4</Rectangle>
<Rectangle is
janky6789>99$5</Rectangle>
<Rectangle is
34+35>99$6</Rectangle>
<Rectangle is
<>>98$7</Rectangle>
<Rectangle is
chicken>3$8</Rectangle>
<Rectangle 1 is
holy>97$9</Rectangle>';
my $regex = qr/<Rectangle[^>]*>3\$[^<]*<\/Rectangle>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}