import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[1,+ ().-][\\s.-]\\d{3}[\\s.-]\\d{3}[\\s.-]\\d{4}";
final String string = "1 203 445 0753\n\n"
+ "1 203 445 0753\n\n"
+ "+1-203-826-7500\n\n"
+ "klhklkkkljugu 1-800-541-0487 7tgtiuguyfglyfgl\n\n"
+ "Fill out the form below, or call 1-800-541-0487\n\n"
+ "1 203 816 7500\n"
+ "1-203-445-0753\n\n"
+ "Fill out the form below completely or call:\n"
+ "1-866-769-9533\n\n"
+ "All fields with (*) are required. ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}