import Foundation
let pattern = #"[1,+ ().-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1 203 445 0753
1 203 445 0753
+1-203-826-7500
klhklkkkljugu 1-800-541-0487 7tgtiuguyfglyfgl
Fill out the form below, or call 1-800-541-0487
1 203 816 7500
1-203-445-0753
Fill out the form below completely or call:
1-866-769-9533
All fields with (*) are required.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)