# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[1,+ ().-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}"
test_str = ("1 203 445 0753\n\n"
"1 203 445 0753\n\n"
"+1-203-826-7500\n\n"
"klhklkkkljugu 1-800-541-0487 7tgtiuguyfglyfgl\n\n"
"Fill out the form below, or call 1-800-541-0487\n\n"
"1 203 816 7500\n"
"1-203-445-0753\n\n"
"Fill out the form below completely or call:\n"
"1-866-769-9533\n\n"
"All fields with (*) are required. ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.