re = /[1,+ ().-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}/
str = '1 203 445 0753
1 203 445 0753
+1-203-826-7500
klhklkkkljugu 1-800-541-0487 7tgtiuguyfglyfgl
Fill out the form below, or call 1-800-541-0487
1 203 816 7500
1-203-445-0753
Fill out the form below completely or call:
1-866-769-9533
All fields with (*) are required. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end