use strict;
my $str = '1 203 445 0753
1 203 445 0753
+1-203-826-7500
klhklkkkljugu 1-800-541-0487 7tgtiuguyfglyfgl
Fill out the form below, or call 1-800-541-0487
1 203 816 7500
1-203-445-0753
Fill out the form below completely or call:
1-866-769-9533
All fields with (*) are required. ';
my $regex = qr/[1,+ ().-][\s.-]\d{3}[\s.-]\d{3}[\s.-]\d{4}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}