#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)name_of_file\K\d*(?=\d{6}\.A\d{3})"
Local $sString = "name_of_file210618.A001.6476871457" & @CRLF & _
"name_of_file0000000546210618.A001.6476871457"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)