use strict;
my $str = 'name_of_file210618.A001.6476871457
name_of_file0000000546210618.A001.6476871457';
my $regex = qr/name_of_file\K\d*(?=\d{6}\.A\d{3})/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";