$re = '/name_of_file\K\d*(?=\d{6}\.A\d{3})/m';
$str = 'name_of_file210618.A001.6476871457
name_of_file0000000546210618.A001.6476871457';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;