const regex = /name_of_file\K\d*(?=\d{6}\.A\d{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('name_of_file\\K\\d*(?=\\d{6}\\.A\\d{3})', 'gm')
const str = `name_of_file210618.A001.6476871457
name_of_file0000000546210618.A001.6476871457`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);