import Foundation
let pattern = #"name_of_file\K\d*(?=\d{6}\.A\d{3})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
name_of_file210618.A001.6476871457
name_of_file0000000546210618.A001.6476871457
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)