#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(".*?"|(?<=:)[^"][0-9]*[^"{}\[\],])|[{}:\[\],]"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "JourneyCode": "TXT123AP3CL700036"," & @CRLF & _
" "CONDITION": "Running Late"," & @CRLF & _
" "earliestarrivalDate": "2017-09-01T14:03:00.001Z"," & @CRLF & _
" "allowedconcessions": [" & @CRLF & _
" {" & @CRLF & _
" "concessionname": "free champagne"," & @CRLF & _
" "concessioncode": "Bolli-911"," & @CRLF & _
" "activationState": "corkpopped"," & @CRLF & _
" "expirydate": "2016-09-01T09:12:33.001Z"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "passenger": {" & @CRLF & _
" "email": "user@example.com"," & @CRLF & _
" "firstName": "John"," & @CRLF & _
" "surname": "Doe"," & @CRLF & _
" "phone": 1234567890," & @CRLF & _
" "language": "en-GB"," & @CRLF & _
" "adress": {" & @CRLF & _
" "street1": "10 Rue Morgue"," & @CRLF & _
" "street2": "string"," & @CRLF & _
" "street3": "string"," & @CRLF & _
" "countyOrState": "Champagne"," & @CRLF & _
" "city": "Epernay"," & @CRLF & _
" "zip": 123456," & @CRLF & _
" "country": "France"" & @CRLF & _
" }" & @CRLF & _
" }," & @CRLF & _
" "ticket": {" & @CRLF & _
" "Number":"StarGla2Ber9ffh46438"," & @CRLF & _
" "JourneyCode": "TXT123AP3CL700036"," & @CRLF & _
" "class": "premium"," & @CRLF & _
" "subclass": "HandleWithCare"," & @CRLF & _
" "franchise": "Eurostar"," & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")