# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\".*?\"|(?<=:)[^\"][0-9]*[^\"{}\[\],])|[{}:\[\],]"
test_str = ("[\n"
" {\n"
" \"JourneyCode\": \"TXT123AP3CL700036\",\n"
" \"CONDITION\": \"Running Late\",\n"
" \"earliestarrivalDate\": \"2017-09-01T14:03:00.001Z\",\n"
" \"allowedconcessions\": [\n"
" {\n"
" \"concessionname\": \"free champagne\",\n"
" \"concessioncode\": \"Bolli-911\",\n"
" \"activationState\": \"corkpopped\",\n"
" \"expirydate\": \"2016-09-01T09:12:33.001Z\"\n"
" }\n"
" ],\n"
" \"passenger\": {\n"
" \"email\": \"user@example.com\",\n"
" \"firstName\": \"John\",\n"
" \"surname\": \"Doe\",\n"
" \"phone\": 1234567890,\n"
" \"language\": \"en-GB\",\n"
" \"adress\": {\n"
" \"street1\": \"10 Rue Morgue\",\n"
" \"street2\": \"string\",\n"
" \"street3\": \"string\",\n"
" \"countyOrState\": \"Champagne\",\n"
" \"city\": \"Epernay\",\n"
" \"zip\": 123456,\n"
" \"country\": \"France\"\n"
" }\n"
" },\n"
" \"ticket\": {\n"
" \"Number\":\"StarGla2Ber9ffh46438\",\n"
" \"JourneyCode\": \"TXT123AP3CL700036\",\n"
" \"class\": \"premium\",\n"
" \"subclass\": \"HandleWithCare\",\n"
" \"franchise\": \"Eurostar\",\n"
" }\n"
" }\n"
"]\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.