using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"("".*?""|(?<=:)[^""][0-9]*[^""{}\[\],])|[{}:\[\],]";
string input = @"[
{
""JourneyCode"": ""TXT123AP3CL700036"",
""CONDITION"": ""Running Late"",
""earliestarrivalDate"": ""2017-09-01T14:03:00.001Z"",
""allowedconcessions"": [
{
""concessionname"": ""free champagne"",
""concessioncode"": ""Bolli-911"",
""activationState"": ""corkpopped"",
""expirydate"": ""2016-09-01T09:12:33.001Z""
}
],
""passenger"": {
""email"": ""user@example.com"",
""firstName"": ""John"",
""surname"": ""Doe"",
""phone"": 1234567890,
""language"": ""en-GB"",
""adress"": {
""street1"": ""10 Rue Morgue"",
""street2"": ""string"",
""street3"": ""string"",
""countyOrState"": ""Champagne"",
""city"": ""Epernay"",
""zip"": 123456,
""country"": ""France""
}
},
""ticket"": {
""Number"":""StarGla2Ber9ffh46438"",
""JourneyCode"": ""TXT123AP3CL700036"",
""class"": ""premium"",
""subclass"": ""HandleWithCare"",
""franchise"": ""Eurostar"",
}
}
]
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}