$re = '/(".*?"|(?<=:)[^"][0-9]*[^"{}\[\],])|[{}:\[\],]/';
$str = '[
{
"JourneyCode": "TXT123AP3CL700036",
"CONDITION": "Running Late",
"earliestarrivalDate": "2017-09-01T14:03:00.001Z",
"allowedconcessions": [
{
"concessionname": "free champagne",
"concessioncode": "Bolli-911",
"activationState": "corkpopped",
"expirydate": "2016-09-01T09:12:33.001Z"
}
],
"passenger": {
"email": "user@example.com",
"firstName": "John",
"surname": "Doe",
"phone": 1234567890,
"language": "en-GB",
"adress": {
"street1": "10 Rue Morgue",
"street2": "string",
"street3": "string",
"countyOrState": "Champagne",
"city": "Epernay",
"zip": 123456,
"country": "France"
}
},
"ticket": {
"Number":"StarGla2Ber9ffh46438",
"JourneyCode": "TXT123AP3CL700036",
"class": "premium",
"subclass": "HandleWithCare",
"franchise": "Eurostar",
}
}
]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);