use strict;
my $str = '[
{
"JourneyCode": "TXT123AP3CL700036",
"CONDITION": "Running Late",
"earliestarrivalDate": "2017-09-01T14:03:00.001Z",
"allowedconcessions": [
{
"concessionname": "free champagne",
"concessioncode": "Bolli-911",
"activationState": "corkpopped",
"expirydate": "2016-09-01T09:12:33.001Z"
}
],
"passenger": {
"email": "user@example.com",
"firstName": "John",
"surname": "Doe",
"phone": 1234567890,
"language": "en-GB",
"adress": {
"street1": "10 Rue Morgue",
"street2": "string",
"street3": "string",
"countyOrState": "Champagne",
"city": "Epernay",
"zip": 123456,
"country": "France"
}
},
"ticket": {
"Number":"StarGla2Ber9ffh46438",
"JourneyCode": "TXT123AP3CL700036",
"class": "premium",
"subclass": "HandleWithCare",
"franchise": "Eurostar",
}
}
]
';
my $regex = qr/(".*?"|(?<=:)[^"][0-9]*[^"{}\[\],])|[{}:\[\],]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}