#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<?FROM database\.)(.+?\b)"
Local $sString = "select a.record_id, a.name, b.person FROM database.atable a join database.btable b on b.id= a.id;" & @CRLF & _
"select c.record_id, c.name, d.person FROM database.ctable c join database.dtable d on c.id= d.id;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")